Vision Care Associates - Youngstown Internet Outage
Incident Report for AEG Vision
Resolved
The outage has cleared and internet server has been restored.
Posted Apr 22, 2024 - 14:53 CDT
Identified
Spectrum advised that there's damage on the pole due to a car accident, the pole is being held up by transmission, dispatch maintenance technician was on the site, however, they need first to wait for the power company to fix the pole and for safety purposes, no ETR posted.
Posted Apr 19, 2024 - 07:50 CDT
This incident affected: ECS of OH (Eye Care Specialties) (Vision Care Associates: Youngstown).