Internet Outage - BeaverCreek
Incident Report for AEG Vision
Resolved
Called in since I saw some computers online and was told the issue has been resolved by Charter.
Posted Apr 25, 2024 - 10:41 CDT
Identified
Called Charter ( Spectrum ) and they said that a fiber line was damaged and they have no estimated time of resolution.
Posted Apr 24, 2024 - 11:37 CDT
This incident affected: VisionMakers (Beavercreek Vision Center).