Spectrum Outage Dallas, TX Area

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 18:08 CDT

Update

The outage has been resolved.
Posted Sep 26, 2025 - 18:08 CDT

Update

An area wide outage is disrupting service in the Dallas, TX area. ETR per Spectrum is 630 PM today.
Posted Sep 26, 2025 - 14:22 CDT

Investigating

We are currently investigating this issue.
Posted Sep 26, 2025 - 14:11 CDT
This incident affected: Insight Complete Eye Care (Insight Complete Eye Care) and ECS of North TX (Eye Care Specialties) (OgleTree Eye Care, North Garland Vision, Optix Eyecare & Gallery, EyeCare Texas, EyeCare Specialties - McKinney).